A structure that has access to the pen properties of lines/curves that are currently being drawn/exported via an export context during a custom export process.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
For more about using properties of this class refer to the interface [!:Autodesk::Revit::DB::IModelExportContext] and its methods which handle geometric objects such as [!:Autodesk::Revit::DB::IModelExportContext::OnCurve], [!:Autodesk::Revit::DB::IModelExportContext::OnLineSegment], etc. LineProperties are available as a read-only property on the respective output nodes, i.e. [!:Autodesk::Revit::DB::CurveNode], [!:Autodesk::Revit::DB::LineSegment], etc.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLineProperties
Autodesk.Revit.DBLineProperties