Line |
A structure that has access to the pen properties of lines/curves that are currently being drawn/exported via an export context during a custom export process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LineProperties type exposes the following members.

Name | Description | |
---|---|---|
![]() | Color | The current color used when drawing lines/curves. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | LineWidth | The current width (thickness) of the pen stroke when drawing lines/curves. |
![]() | PatternId | Id of the current Line pattern element used when drawing lines/curves. |
![]() | Transparency | The current transparency level to be applied to the current color. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the LineProperties |

For more about using properties of this class refer to the interface IModelExportContext and its methods which handle geometric objects such as OnCurve(CurveNode) , OnLineSegment(LineSegment) , etc. LineProperties are available as a read-only property on the respective output nodes, i.e. CurveNode , LineSegment , etc.