LineProperties Class


Line Properties Class

A structure that has access to the pen properties of lines/curves that are currently being drawn/exported via an export context during a custom export process.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB LineProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LineProperties : IDisposable

The LineProperties type exposes the following members.

Properties
Name Description
Public property Color The current color used when drawing lines/curves.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LineWidth The current width (thickness) of the pen stroke when drawing lines/curves.
Public property PatternId Id of the current Line pattern element used when drawing lines/curves.
Public property Transparency The current transparency level to be applied to the current color.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the LineProperties
Top
Remarks
For more about using properties of this class refer to the interface [!:Autodesk::Revit::DB::IModelExportContext] and its methods which handle geometric objects such as [!:Autodesk::Revit::DB::IModelExportContext::OnCurve] , [!:Autodesk::Revit::DB::IModelExportContext::OnLineSegment] , etc. LineProperties are available as a read-only property on the respective output nodes, i.e. [!:Autodesk::Revit::DB::CurveNode] , [!:Autodesk::Revit::DB::LineSegment] , etc.
See Also