Converts the geometry stored in the external format into a collection of Revit geometry objects.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The Revit document where the resulting Revit geometry objects will be used. This document may need to be modified to store dependent elements such as graphics styles and/or materials.
- filename
- Type: SystemString
The full path to the input file.
Return Value
A collection of Revit geometry objects created from the incoming data.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsFileArgumentNotFoundException | The given filename does not exist. |
Autodesk.Revit.ExceptionsInvalidOperationException | Data conversion service is not available. |