Convert Method


Shape Importer Convert Method

Converts the geometry stored in the external format into a collection of Revit geometry objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public IList<GeometryObject> Convert(
	Document document,
	string filename
)

Parameters

document Document
The Revit document where the resulting Revit geometry objects will be used. This document may need to be modified to store dependent elements such as graphics styles and/or materials.
filename String
The full path to the input file.

Return Value

IList GeometryObject
A collection of Revit geometry objects created from the incoming data.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
FileArgumentNotFoundException The given filename does not exist.
InvalidOperationException Data conversion service is not available, or the Material Library is missing.
See Also