Shape |
Converts the geometry stored in the external format into a collection of Revit geometry objects.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- The Revit document where the resulting Revit geometry objects will be used. This document may need to be modified to store dependent elements such as graphics styles and/or materials.
- filename String
- The full path to the input file.
Return Value
IList GeometryObjectA collection of Revit geometry objects created from the incoming data.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
FileArgumentNotFoundException | The given filename does not exist. |
InvalidOperationException | Data conversion service is not available. |