SetPresenceOfSegments Method


Simultaneously set the presence of all 3D segments.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetPresenceOfSegments(
	bool isDuplicateShapePresent,
	bool isStartConnectorPresent,
	bool isEndConnectorPresent
)
Visual Basic
Public Sub SetPresenceOfSegments ( _
	isDuplicateShapePresent As Boolean, _
	isStartConnectorPresent As Boolean, _
	isEndConnectorPresent As Boolean _
)
Visual C++
public:
void SetPresenceOfSegments(
	bool isDuplicateShapePresent, 
	bool isStartConnectorPresent, 
	bool isEndConnectorPresent
)

Parameters

isDuplicateShapePresent
Type: SystemBoolean
isStartConnectorPresent
Type: SystemBoolean
isEndConnectorPresent
Type: SystemBoolean

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentsInconsistentException The shape is disconnected or forms a complete loop: If the duplicate shape is present, exactly one of the connectors must be present.

See Also