Rebar |
Simultaneously set the presence of all 3D segments.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetPresenceOfSegments(
bool isDuplicateShapePresent,
bool isStartConnectorPresent,
bool isEndConnectorPresent
)
Parameters

Exception | Condition |
---|---|
ArgumentsInconsistentException | The shape is disconnected or forms a complete loop: If the duplicate shape is present, exactly one of the connectors must be present. |