GetTemperature Method


Gets a copy of the FluidTemperature object matching a given temperature value.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public FluidTemperature GetTemperature(
	double temperature
)
Visual Basic
Public Function GetTemperature ( _
	temperature As Double _
) As FluidTemperature
Visual C++
public:
FluidTemperature^ GetTemperature(
	double temperature
)

Parameters

temperature
Type: SystemDouble
The temperature value.

Return Value

The fluid temperature. a null reference (Nothing in Visual Basic) if not found.

Remarks

Changes made to this object will not be applied to the FluidType object. In order to modify the FluidTemperature settings for a given temperature, you should remove the existing FluidTemperature (RemoveTemperature()) and then add the modified value (AddTemperature()).

See Also