Represents a fill pattern object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
Fill patterns control the appearance of surfaces that are cut or shown in projection. A simple fill pattern consists of a series of parallel or orthogonal lines. Note - Dots are coded as zero-length dashes in the fill pattern definition. When the Revit graphic engine encounters a zero-length line it simply ignores it and doesn't draw anything. So call ExpandDots() for the patterns you construct to convert dots to small dashes, so that the rendering of the FillPattern is correct.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFillPattern
Autodesk.Revit.DBFillPattern