Fill |
Represents a fill pattern object.

System Object
Autodesk.Revit.DB FillPattern
Autodesk.Revit.DB FillPattern
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The FillPattern type exposes the following members.

Name | Description | |
---|---|---|
![]() | FillPattern | Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE. |
![]() | FillPattern(FillPattern) | Constructs a new copy of the input FillPattern object. |
![]() | FillPattern(String, FillPatternTarget, FillPatternHostOrientation) | Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation. |
![]() | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double) | Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation. |
![]() | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) | Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation. |

Name | Description | |
---|---|---|
![]() | GridCount | Gets the count of the fill grids in this fill pattern. |
![]() | HostOrientation | Orientation to host layer. |
![]() | IsSolidFill | Check if the fill pattern is a solid fill pattern. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | LengthPerArea | Gets length of all lines that placed on unit area. |
![]() | LinesPerLength | Gets the number of solid lines that placed in unit length. |
![]() | Name | The name of the fill pattern. |
![]() | StrokesPerArea | Gets the number of strokes that placed on unit area. |
![]() | Target | Target of this fill pattern applied to. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FillPattern |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | ExpandDots | Corrects pattern dots to make them be drawn properly for Revit. |
![]() ![]() | ExportToPAT | |
![]() | GetFillGrid | Gets the specified fill grid. |
![]() | GetFillGrids | Gets all fill grids in this fill pattern |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsEqual | Check if the contents and the name of the fill pattern is the same as the name and contents of this fill pattern. |
![]() | SetFillGrid | Sets the fill grid. |
![]() | SetFillGrids | |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Fill patterns control the appearance of surfaces that are cut or shown in projection. A simple fill pattern consists of a series of parallel or orthogonal lines. Note - Dots are coded as zero-length dashes in the fill pattern definition. When the Revit graphic engine encounters a zero-length line it simply ignores it and doesn't draw anything. So call ExpandDots() for the patterns you construct to convert dots to small dashes, so that the rendering of the FillPattern is correct.