FillPattern Class


Fill Pattern Class

Represents a fill pattern object.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FillPattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FillPattern : IDisposable

The FillPattern type exposes the following members.

Constructors
Name Description
Public method FillPattern Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE.
Public method FillPattern(FillPattern) Constructs a new copy of the input FillPattern object.
Public method FillPattern(String, FillPatternTarget, FillPatternHostOrientation) Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.
Public method FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double) Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Public method FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Top
Properties
Name Description
Public property GridCount Gets the count of the fill grids in this fill pattern.
Public property HostOrientation Orientation to host layer.
Public property IsSolidFill Check if the fill pattern is a solid fill pattern.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LengthPerArea Gets length of all lines that placed on unit area.
Public property LinesPerLength Gets the number of solid lines that placed in unit length.
Public property Name The name of the fill pattern.
Public property StrokesPerArea Gets the number of strokes that placed on unit area.
Public property Target Target of this fill pattern applied to.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FillPattern
Public method ExpandDots Corrects pattern dots to make them be drawn properly for Revit.
Public method Static member ExportToPAT Export a list of FillPatterns to an AutoCAD PAT file.
Public method GetFillGrid Gets the specified fill grid.
Public method GetFillGrids Gets all fill grids in this fill pattern
Public method IsEqual Check if the contents and the name of the fill pattern is the same as the name and contents of this fill pattern.
Public method SetFillGrid Sets the fill grid.
Public method SetFillGrids Set the fill grids in this fill pattern.
Top
Remarks
Fill patterns control the appearance of surfaces that are cut or shown in projection. A simple fill pattern consists of a series of parallel or orthogonal lines. Note - Dots are coded as zero-length dashes in the fill pattern definition. When the Revit graphic engine encounters a zero-length line it simply ignores it and doesn't draw anything. So call ExpandDots() for the patterns you construct to convert dots to small dashes, so that the rendering of the FillPattern is correct.
See Also