Create a non-periodic Hermite surface using a net of 3D points as input.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- nU
- Type: SystemInt32
Number of points in U direction.
- nV
- Type: SystemInt32
Number of points in V direction.
- points
- Type: System.Collections.GenericIListXYZ
Array of points. Must contain nU*nV points.
Return Value
A Hermite surface object created from input data.Remarks
Points form a net of nU * nV 3D points. Suitable defaults will be used for other surface parameters. See other Create() functions if greater control over input is desired.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentsInconsistentException | Thrown when the input arguments are inconsistent. The most common case is incorrect number of items in one of the lists. |