Hermite |
Create a non-periodic Hermite surface using a net of 3D points as input.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- nU Int32
- Number of points in U direction.
- nV Int32
- Number of points in V direction.
- points IList XYZ
- Array of points. Must contain nU*nV points.
Return Value
HermiteSurfaceA Hermite surface object created from input data.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentsInconsistentException | Thrown when the input arguments are inconsistent. The most common case is incorrect number of items in one of the lists. |

Points form a net of nU * nV 3D points. Suitable defaults will be used for other surface parameters. See other Create() functions if greater control over input is desired.