GetVisibility Method


Gets the SSE point visibility for the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public static bool GetVisibility(
	Document document,
	ElementId categoryId
)
Visual Basic
Public Shared Function GetVisibility ( _
	document As Document, _
	categoryId As ElementId _
) As Boolean
Visual C++
public:
static bool GetVisibility(
	Document^ document, 
	ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
categoryId
Type: Autodesk.Revit.DBElementId
The category id.

Return Value

The visibility of the given category. True means the SSE points are visible.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The category is not valid for SSE.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also