Returns a transformation that is applied to elements when copying from one view to another view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- sourceView
- Type: Autodesk.Revit.DBView
The source view
- destinationView
- Type: Autodesk.Revit.DBView
The destination view
Return Value
The transformation from source view to destination view.Remarks
Both source and destination views must be 2D graphics views capable of drawing details and view-specific elements (floor and ceiling plans, elevations, sections, drafting views.) The result is a transformation needed to copy an element from drawing plane of the source view to the drawing plane of the destination view. The destination view can be in the same document as the source view. The destination view can be the same as the source view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The specified view cannot be used as a source or destination for copying elements between two views. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |