Get the parameter value for a bar at the specified index. The parameter Id. The bar index in the rebar distribution. Accepts only values between 0 and NumberOfBarPositions-1. The ParameterValue for given parameterId and barPositionIndex. Throws exception if barPositionIndex is outside boundaries.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
If the DistributionType is Uniform then the returned ParameterValue is the same no matter the index. If the DistributionType is VaryingLength then the returned ParameterValue is evaluated at the given index.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |