GetParameterValueAtIndex Method


Rebar Get Parameter Value At Index Method

Get the parameter value for a bar at the specified index.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ParameterValue GetParameterValueAtIndex(
	ElementId paramId,
	int barPositionIndex
)

Parameters

paramId ElementId
The parameter Id.
barPositionIndex Int32
The bar index in the rebar distribution. Accepts only values between 0 and NumberOfBarPositions-1.

Return Value

ParameterValue
The ParameterValue for given parameterId and barPositionIndex.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException barPositionIndex should be in range [ 0, NumberOfBarPositions-1 ] and the bar at barPositionIndex should be included.
Remarks
For rebar sets which don't have varying length bars the returned ParameterValue is the same no matter the index. For rebar sets which have varying length bars the returned ParameterValue is evaluated at the given index.
See Also