Rebar Get |
Get the parameter value for a bar at the specified index.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public ParameterValue GetParameterValueAtIndex(
ElementId paramId,
int barPositionIndex
)
Parameters
- paramId ElementId
- The parameter Id.
- barPositionIndex Int32
- The bar index in the rebar distribution. Accepts only values between 0 and NumberOfBarPositions-1.
Return Value
ParameterValueThe ParameterValue for given parameterId and barPositionIndex.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |

For rebar sets which don't have varying length bars the returned ParameterValue is the same no matter the index. For rebar sets which have varying length bars the returned ParameterValue is evaluated at the given index.