GetEndTreatmentTypeId Method


Rebar Shape Get End Treatment Type Id Method

Note: This API is now obsolete.

Gets the id of the EndTreatmentType at the specified rebar shape end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarShape.GetTerminationsData().EndTreatmentTypeIdAtStart or RebarShape.GetTerminationsData().EndTreatmentTypeIdAtEnd instead.")]
public ElementId GetEndTreatmentTypeId(
	int end
)

Parameters

end Int32
0 for the start end treatment, 1 for the end end treatment.

Return Value

ElementId
Returns the id of an EndTreatmentType, or invalidElementId if the rebar shape has no end treatment at the specified end.
Exceptions
Exception Condition
ArgumentException end not a valid shape end
See Also