GetEndTreatmentTypeId Method


Rebar Shape Get End Treatment Type Id Method

Gets the id of the EndTreatmentType at the specified rebar shape end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId GetEndTreatmentTypeId(
	int iEnd
)

Parameters

iEnd Int32
0 for the start end treatment, 1 for the end end treatment.

Return Value

ElementId
Returns the id of an EndTreatmentType, or invalidElementId if the rebar shape has no end treatment at the specified end.
Exceptions
Exception Condition
ArgumentException iEnd not a valid shape end
See Also