GetLabelForSymbol Method


Gets the user-visible name for a symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static string GetLabelForSymbol(
	ForgeTypeId symbolTypeId
)
Visual Basic
Public Shared Function GetLabelForSymbol ( _
	symbolTypeId As ForgeTypeId _
) As String
Visual C++
public:
static String^ GetLabelForSymbol(
	ForgeTypeId^ symbolTypeId
)

Parameters

symbolTypeId
Type: Autodesk.Revit.DBForgeTypeId
Identifier of the symbol to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Symbol must have a definition.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also