IsEqualTo Method


Compare this object with the one supplied as argument. Return true if the options specified by both objects are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2021

Syntax

C#
public bool IsEqualTo(
	DirectShapeTypeOptions other
)
Visual Basic
Public Function IsEqualTo ( _
	other As DirectShapeTypeOptions _
) As Boolean
Visual C++
public:
bool IsEqualTo(
	DirectShapeTypeOptions^ other
)

Parameters

other
Type: Autodesk.Revit.DBDirectShapeTypeOptions
the DirectShapeTypeOptions object to be compared.

Return Value

True if both objects specify the same options.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also