Creates a new RebarHookType in a document.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DBDocument
- angle
- Type: SystemDouble
Determine the hook angle of new RebarHookType.
- multiplier
- Type: SystemDouble
Determine the straight line multiplier of new RebarHookType.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given value for angle is not a number -or- The given value for multiplier is not a number |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | angle must be greater than 0 and no more than pi. -or- multiplier must be greater than 0 and no more than 99. |