Create Method


Rebar Hook Type Create Method

Creates a new RebarHookType in a document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static RebarHookType Create(
	Document doc,
	double angle,
	double multiplier
)

Parameters

doc Document
angle Double
Determine the hook angle in radians of new RebarHookType. Must be greater than 0.0174532925 (1 degree) and no more than PI (180 degree).
multiplier Double
Determine the straight line multiplier of new RebarHookType.

Return Value

RebarHookType
Exceptions
Exception Condition
ArgumentException The given value for angle is not a number -or- The given value for multiplier is not a number
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException angle must be greater than 0.0174532925 (1 degree) and no more than PI (180 degree). -or- multiplier must be greater than 0 and no more than 99.
See Also