Rebar |
Creates a new RebarHookType in a document.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- doc Document
- angle Double
- Determine the hook angle of new RebarHookType.
- multiplier Double
- Determine the straight line multiplier of new RebarHookType.
Return Value
RebarHookType
Exception | Condition |
---|---|
ArgumentException | The given value for angle is not a number -or- The given value for multiplier is not a number |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | angle must be greater than 0 and no more than pi. -or- multiplier must be greater than 0 and no more than 99. |