Creates a new BeamSystem with specified profile curves.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document in which the new BeamSystem is created.
- profile
- Type: System.Collections.GenericIListCurve
The profile of the BeamSystem.
- sketchPlane
- Type: Autodesk.Revit.DBSketchPlane
The work-plane for the BeamSystem.
- direction
- Type: Autodesk.Revit.DBXYZ
The direction is the direction of the BeamSystem.
- is3d
- Type: SystemBoolean
Whether the BeamSystem is 3D. If the BeamSystem is 3D, the sketchPlane must be a level, otherwise an exception will be thrown.
Return Value
If successful, a new BeamSystem object will be returned.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | SketchPlane is not valid for BeamSystem creation. -or- The input profile contains at least one helical curve and is not supported for this operation. -or- The profile curves must be in the sketch plane. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The BeamSystem is 3D, but the SketchPlane is not a level. |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |