Create Method (Document, IList(Curve), SketchPlane, XYZ, Boolean)


Beam System Create(Document, IList Curve , Sketch Plane, XYZ, Boolean) Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static BeamSystem Create(
	Document document,
	IList<Curve> profile,
	SketchPlane sketchPlane,
	XYZ direction,
	bool is3d
)

Parameters

document Document
profile IList Curve
sketchPlane SketchPlane
direction XYZ
is3d Boolean

Return Value

BeamSystem
See Also