Create Method (Document, IList(Curve), SketchPlane, XYZ, Boolean)


Beam System Create(Document, IList Curve , Sketch Plane, XYZ, Boolean) Method

Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static BeamSystem Create(
	Document document,
	IList<Curve> profile,
	SketchPlane sketchPlane,
	XYZ direction,
	bool is3d
)

Parameters

document Document
The document in which the new BeamSystem is created.
profile IList Curve
The profile of the BeamSystem.
sketchPlane SketchPlane
The work-plane for the BeamSystem.
direction XYZ
The direction is the direction of the BeamSystem.
is3d Boolean
Whether the BeamSystem is 3D. If the BeamSystem is 3D, the sketchPlane must be a level, otherwise an exception will be thrown.

Return Value

BeamSystem
If successful, a new BeamSystem object will be returned.
Exceptions
Exception Condition
ArgumentException SketchPlane is not valid for BeamSystem creation. -or- The input profile contains at least one helical curve and is not supported for this operation. -or- The profile curves must be in the sketch plane.
ArgumentNullException A non-optional argument was null
InvalidOperationException The BeamSystem is 3D, but the SketchPlane is not a level.
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also