Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- nU
- Type: SystemInt32
Number of points in U direction.
- nV
- Type: SystemInt32
Number of points in V direction.
- points
- Type: System.Collections.GenericIListXYZ
Array of points. Must contain nU*nV points.
- periodicU
- Type: SystemBoolean
Periodicity in U direction
- periodicV
- Type: SystemBoolean
Periodicity in V direction
Return Value
A Hermite surface object created from input data.Remarks
Points form a net of nU * nV (less one each if periodic) 3D points.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentsInconsistentException | Thrown when the input arguments are inconsistent. The most common case is incorrect number of items in one of the lists. |