Create Method (Int32, Int32, IList(XYZ), Boolean, Boolean)


Hermite Surface Create(Int 32, Int 32, IList XYZ , Boolean, Boolean) Method

Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static HermiteSurface Create(
	int nU,
	int nV,
	IList<XYZ> points,
	bool periodicU,
	bool periodicV
)

Parameters

nU Int32
Number of points in U direction.
nV Int32
Number of points in V direction.
points IList XYZ
Array of points. Must contain nU*nV points.
periodicU Boolean
Periodicity in U direction
periodicV Boolean
Periodicity in V direction

Return Value

HermiteSurface
A Hermite surface object created from input data.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentsInconsistentException Thrown when the input arguments are inconsistent. The most common case is incorrect number of items in one of the lists.
Remarks
Points form a net of nU * nV (less one each if periodic) 3D points.
See Also