Create Method


Creates a new instance of a demand factor definition.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static ElectricalDemandFactorDefinition Create(
	Document ADoc,
	string strName
)
Visual Basic
Public Shared Function Create ( _
	ADoc As Document, _
	strName As String _
) As ElectricalDemandFactorDefinition
Visual C++
public:
static ElectricalDemandFactorDefinition^ Create(
	Document^ ADoc, 
	String^ strName
)

Parameters

ADoc
Type: Autodesk.Revit.DBDocument
The document where the element will be created and added.
strName
Type: SystemString
The name of the electrical demand factor definition to be created.

Return Value

The newly created demand factor definition element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also