GetPropagationViews Method


Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public ISet<ElementId> GetPropagationViews(
	View view
)
Visual Basic
Public Function GetPropagationViews ( _
	view As View _
) As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetPropagationViews(
	View^ view
)

Parameters

view
Type: Autodesk.Revit.DBView
The view on which the DatumPlane shows.

Return Value

A set of ElementIds of the parallel views for extent propagation.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The datum plane cannot be visible in the view.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also