GetCellText Method


Gets the cell's text based on its type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public string GetCellText(
	SectionType sectionType,
	int row,
	int column
)
Visual Basic
Public Function GetCellText ( _
	sectionType As SectionType, _
	row As Integer, _
	column As Integer _
) As String
Visual C++
public:
String^ GetCellText(
	SectionType sectionType, 
	int row, 
	int column
)

Parameters

sectionType
Type: Autodesk.Revit.DBSectionType
The requested section type
row
Type: SystemInt32
Row Number in the Section
column
Type: SystemInt32
Column Number in the Section

Return Value

The text for the given cell

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The sectionType is not a valid type for this view.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The given row number row is invalid. -or- The given column number column is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration

See Also