Checks whether a field can be used with a value presence-based filter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fieldId
- Type: Autodesk.Revit.DBScheduleFieldId
The ID of the field to check.
Return Value
True if the field can be used with a value presence filter, false otherwise.Remarks
The value presence filter types are HasValue and HasNoValue.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | fieldId is not the ID of a field in this ScheduleDefinition. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |