CanFilterByValuePresence Method


Schedule Definition Can Filter By Value Presence Method

Checks whether a field can be used with a value presence-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool CanFilterByValuePresence(
	ScheduleFieldId fieldId
)

Parameters

fieldId ScheduleFieldId
The ID of the field to check.

Return Value

Boolean
True if the field can be used with a value presence filter, false otherwise.
Exceptions
Exception Condition
ArgumentException fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException A non-optional argument was null
Remarks
The value presence filter types are HasValue and HasNoValue.
See Also