Location |
Provides location functionality for all elements that have a single insertion point.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Location
Autodesk.Revit.DB LocationPoint
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Location
Autodesk.Revit.DB LocationPoint
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The LocationPoint type exposes the following members.

Name | Description | |
---|---|---|
![]() | Point | The physical location of the element. |
![]() | Rotation | The angle of rotation around the insertion point, in radians. |

Name | Description | |
---|---|---|

The location point objects adds additional functionality to its base location object class. This includes setting the elements location to a specific point and retrieving its rotation around its insertion point. Inplace families do not have a single insertion point and therefore do not have meaningful LocationPoint data.