Location |
Provides location functionality for all elements that have a single insertion point.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Location
Autodesk.Revit.DB LocationPoint
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Location
Autodesk.Revit.DB LocationPoint
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LocationPoint type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | Point | The physical location of the element. |
![]() | Rotation | The angle of rotation around the insertion point, in radians. |

Name | Description | |
---|---|---|

The location point objects adds additional functionality to its base location object class. This includes setting the elements location to a specific point and retrieving its rotation around its insertion point. Inplace families do not have a single insertion point and therefore do not have meaningful LocationPoint data.

void LocationInformation(LocationPoint position)
{
String prompt = "The selected column location information:";
prompt += "\nPoint: (" + position.Point.X + ", "
+ position.Point.Y + ", " + position.Point.Z + ")";
prompt += "\nRotation: " + position.Rotation;
TaskDialog.Show("Revit",prompt);
}
bool LocationRotate(Autodesk.Revit.ApplicationServices.Application application, Autodesk.Revit.DB.Element element)
{
bool rotated = false;
LocationPoint location = element.Location as LocationPoint;
if (null != location)
{
XYZ aa = location.Point;
XYZ cc = new XYZ(aa.X, aa.Y, aa.Z + 10);
Line axis = Line.CreateBound(aa,cc);
rotated = location.Rotate(axis, Math.PI / 2.0);
}
return rotated;
}