LocationPoint Class


Location Point Class

Provides location functionality for all elements that have a single insertion point.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Location
Autodesk.Revit.DB LocationPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LocationPoint : Location

The LocationPoint type exposes the following members.

Properties
Name Description
Public property IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Point The physical location of the element.
Public property Rotation The angle of rotation around the insertion point, in radians.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Move Move the element within the project by a specified vector.
(Inherited from Location )
Public method Rotate Rotate the element within the project by a specified angle around a given axis.
(Inherited from Location )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The location point objects adds additional functionality to its base location object class. This includes setting the elements location to a specific point and retrieving its rotation around its insertion point. Inplace families do not have a single insertion point and therefore do not have meaningful LocationPoint data.
See Also