CorrectionFactor Class


Correction Factor Class

Represents electrical correction factor information.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB.Electrical CorrectionFactor

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CorrectionFactor : APIObject

The CorrectionFactor type exposes the following members.

Properties
Name Description
Public property Factor Get factor value of wire correction factor.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetTemperature Get temperature which is used for specifying correction factor. The value returned is quantified in the document's selected unit of electrical temperature.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Correction factor is defined based on corresponding wire material type and temperature rating type.
See Also