CorrectionFactor Class


Correction Factor Class

Represents electrical correction factor information.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB.Electrical CorrectionFactor

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CorrectionFactor : APIObject

The CorrectionFactor type exposes the following members.

Properties
Name Description
Public property Factor Get factor value of wire correction factor.
Top
Methods
Name Description
Public method GetTemperature Get temperature which is used for specifying correction factor. The value returned is quantified in the document's selected unit of electrical temperature.
Top
Remarks
Correction factor is defined based on corresponding wire material type and temperature rating type.
See Also