Grid Create(Document, Line) Method |
Creates a new grid line.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Parameters
- document Document
- The document in which the new instance is created.
- line Line
- A line which represents the location of the grid line.
Return Value
GridThe newly created grid line.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- The input line is not on horizontal plane. |
ArgumentNullException | A non-optional argument was null |

The line should be on a horizontal plane.