Grid Create(Document, Line) Method |
Creates a new grid line.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- The document in which the new instance is created.
- line Line
- A line which represents the location of the grid line.
Return Value
GridThe newly created grid line.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- The input line is not on horizontal plane. |
ArgumentNullException | A non-optional argument was null |

The line should be on a horizontal plane.

// Create the geometry line which the grid locates
XYZ start = new XYZ(0, 0, 0);
XYZ end = new XYZ(30, 30, 0);
Line geomLine = Line.CreateBound(start, end);
// Create a grid using the geometry line
Grid lineGrid = Grid.Create(document, geomLine);
if (null == lineGrid)
{
throw new Exception("Create a new straight grid failed.");
}
// Modify the name of the created grid
lineGrid.Name = "New Name1";