Create Method (Document, Line)


Grid Create(Document, Line) Method

Creates a new grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static Grid Create(
	Document document,
	Line line
)

Parameters

document Document
The document in which the new instance is created.
line Line
A line which represents the location of the grid line.

Return Value

Grid
The newly created grid.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- The input line is not on a horizontal plane.
ArgumentNullException A non-optional argument was null
Remarks
The line should be on a horizontal plane.
See Also