Externally |
An ExternallyTaggedSolid can hold any shape created by BRepBuilder.

System Object
Autodesk.Revit.DB ExternallyTaggedGeometryObject
Autodesk.Revit.DB ExternallyTaggedBRep
Autodesk.Revit.DB ExternallyTaggedGeometryObject
Autodesk.Revit.DB ExternallyTaggedBRep
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ExternallyTaggedBRep type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExternalId | The external Id of the geometry object. (Inherited from ExternallyTaggedGeometryObject ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternallyTaggedGeometryObject ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from ExternallyTaggedGeometryObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetTaggedGeometry | Returns the externally tagged geometry object. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |