ExternallyTaggedBRep Class


Externally Tagged BRep Class

An ExternallyTaggedSolid can hold any shape created by BRepBuilder.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternallyTaggedBRep : ExternallyTaggedGeometryObject

The ExternallyTaggedBRep type exposes the following members.

Properties
Name Description
Public property ExternalId The external Id of the geometry object.
(Inherited from ExternallyTaggedGeometryObject )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ExternallyTaggedGeometryObject )
Top
Methods
Name Description
Public method Dispose
(Inherited from ExternallyTaggedGeometryObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetTaggedGeometry Returns the externally tagged geometry object.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also