Leader Class |
A leader object that can be attached to annotation elements such as text notes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The Leader type exposes the following members.

Name | Description | |
---|---|---|
![]() | Anchor | Anchor point of the Leader |
![]() | Elbow | Elbow point of the Leader. |
![]() | End | End point of the Leader. |
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | LeaderShape | Geometric style of the leader |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

For information on how to attach or get leaders to/from a text annotation refer to corresponding methods of TextNote class.