Leader Class


Leader Class

A leader object that can be attached to annotation elements such as text notes.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Leader

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class Leader : APIObject

The Leader type exposes the following members.

Properties
Name Description
Public property Anchor Anchor point of the Leader
Public property Elbow Elbow point of the Leader.
Public property End End point of the Leader.
Public property IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LeaderShape Geometric style of the leader
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
For information on how to attach or get leaders to/from a text annotation refer to corresponding methods of [!:Autodesk::Revit::DB::TextNote] class.
See Also