Detail |
A utility class that arranges the draw order of the detail elements.

System Object
Autodesk.Revit.DB DetailElementOrderUtils
Autodesk.Revit.DB DetailElementOrderUtils
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The DetailElementOrderUtils type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | AreDetailElements | |
![]() ![]() | BringForward(Document, View, ElementId) | Moves the given detail instance one step closer to the front of all other detail instances in the view. |
![]() ![]() | BringForward(Document, View, ICollection ElementId ) | |
![]() ![]() | BringToFront(Document, View, ElementId) | Places the given detail instance in the front of all other detail instances in the view. |
![]() ![]() | BringToFront(Document, View, ICollection ElementId ) | |
![]() ![]() | GetDrawOrderForDetails | |
![]() ![]() | IsDetailElement | Indicates if the element is a detail element that participates in detail draw ordering in the view. |
![]() ![]() | SendBackward(Document, View, ElementId) | Moves the given detail instance one step closer to the back of all other detail instances in the view. |
![]() ![]() | SendBackward(Document, View, ICollection ElementId ) | |
![]() ![]() | SendToBack(Document, View, ElementId) | Places the given detail instance behind all detail instances in the view. |
![]() ![]() | SendToBack(Document, View, ICollection ElementId ) |