Detail |
A utility class that arranges the draw order of the detail elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The DetailElementOrderUtils type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | AreDetailElements | Indicates if the elements are all detail elements that participate in detail draw ordering in the view. |
![]() ![]() | BringForward(Document, View, ElementId) | Moves the given detail instance one step closer to the front of all other detail instances in the view. |
![]() ![]() | BringForward(Document, View, ICollection ElementId ) | Moves the given detail instances one step closer to the front of all other detail instances in the view, while keeping the order of the given ones. |
![]() ![]() | BringToFront(Document, View, ElementId) | Places the given detail instance in the front of all other detail instances in the view. |
![]() ![]() | BringToFront(Document, View, ICollection ElementId ) | Places the given detail instances in the front of all other detail instances in the view, while keeping the order of the given ones. |
![]() ![]() | GetDrawOrderForDetails | Returns the given detail elements according to the currently specified draw order for the detail elements in a given view. |
![]() ![]() | IsDetailElement | Indicates if the element is a detail element that participates in detail draw ordering in the view. |
![]() ![]() | SendBackward(Document, View, ElementId) | Moves the given detail instance one step closer to the back of all other detail instances in the view. |
![]() ![]() | SendBackward(Document, View, ICollection ElementId ) | Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones. |
![]() ![]() | SendToBack(Document, View, ElementId) | Places the given detail instance behind all detail instances in the view. |
![]() ![]() | SendToBack(Document, View, ICollection ElementId ) | Places the given detail instances behind all other detail instances in the view, while keeping the order of the given ones. |