DetailElementOrderUtils Class


Detail Element Order Utils Class

A utility class that arranges the draw order of the detail elements.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB DetailElementOrderUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class DetailElementOrderUtils

The DetailElementOrderUtils type exposes the following members.

Methods
Name Description
Public method Static member AreDetailElements
Public method Static member BringForward(Document, View, ElementId) Moves the given detail instance one step closer to the front of all other detail instances in the view.
Public method Static member BringForward(Document, View, ICollection ElementId )
Public method Static member BringToFront(Document, View, ElementId) Places the given detail instance in the front of all other detail instances in the view.
Public method Static member BringToFront(Document, View, ICollection ElementId )
Public method Static member GetDrawOrderForDetails
Public method Static member IsDetailElement Indicates if the element is a detail element that participates in detail draw ordering in the view.
Public method Static member SendBackward(Document, View, ElementId) Moves the given detail instance one step closer to the back of all other detail instances in the view.
Public method Static member SendBackward(Document, View, ICollection ElementId )
Public method Static member SendToBack(Document, View, ElementId) Places the given detail instance behind all detail instances in the view.
Public method Static member SendToBack(Document, View, ICollection ElementId )
Top
See Also